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1. Introduction 
CazCoin is an ecommerce platform, with its ‘Caz Shop’ launched on June 8 2018, it’s the first 

cryptocurrency ecommerce platform! Visit our website to see the platform and be impressed. 

As a Masternode and Staking coin, masternode owners and stakers are handsomely rewarded to 

continuously operate the blockchain. And best of all, if you run your masternode on a VPS service, you 

don’t need to keep your computer on 24/7; just check your wallet when you want to see your rewards! 

If setting up a masternode via VPS sounds daunting, another option is to use a hosted masternode 

service, such as NodeShare. 

For the current masternode specifications and ROI, see Masternodes.Online 

2. Requirements 
 50,000.01 Caz Coins. These can be purchased via: 

o Coinexchange; or 

o Cryptobridge. 

Note: Check CazCoin website for up-to-date exchange listings. 

 Download the latest CazCoin wallet via the CazCoin website. After it’s downloaded, ensure it’s 

fully synced before beginning; 

 In your wallet, go to Settings > Options > Wallet, and tick the box for ‘Enable coin control 

features’ (this helps you select the correct collateral to send); 

 A Virtual Private Server (VPS). Explanation for this in Section 3; 

 Download and install Putty. This is used to access the VPS and enter commands; and 

 Have a Notepad or Word document open for recording details. 

Note: Back up your wallet regularly. Do it before and after this process, and after creating new 

addresses within your wallet. 

A good practice is to store the backed-up wallet.dat file on an encrypted USB drive or hard drive and 

store offsite. 

 

*Sometimes running a masternode is not for the faint-hearted, as on occasions issues can occur that 

may take time to rectify, but if you’re unable to fix them, please feel free to contact the CazCoin admin 

team on Telegram. 

  

https://www.nodeshare.in/
https://masternodes.online/currencies/CAZ/
https://www.coinexchange.io/market/CAZ/BTC
https://wallet.crypto-bridge.org/market/BRIDGE.CAZ_BRIDGE.BTC
http://cazcoin.io/
http://cazcoin.io/
http://www.putty.org/
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3. Block Rewards? 
The block time (time it takes for a new block to be made) is 90 seconds, however the reward structure 

per block changes depending on where the block count is at (this can be checked at the CazCoin 

Explorer). The rewards for masternodes and staking can be seen below. 

 

 

 

 

 

 

 

 

 

 

 

 

4. VPS Preparation 
Choose a VPS provider. A cheap and easy to use one is Digital Ocean. Once you’ve created an account 

and set-up billing details, creating a ‘droplet’ (where your masternode sits) takes around a minute. 

For your droplet, you will need the following minimum requirements; 

 Ubuntu 16.04. 

 1GB Memory. 

 25GB SSD. 

 1TB transfer. 

(The minimum droplet on Digital Ocean has all of the above requirements for approx. $5 a 

month.) 

 Any datacentre region is fine. 

 No additional options are required; 

 No need to add SSH keys 

Hostname: Choose something that you will recognise, especially if you have multiple masternodes, such 

as ‘CazMN1’. 

When you’ve set your droplet up, Digital Ocean (or chosen provider) will email you with login details, 

including the VPS_IP address (which is also listed on the Digital Ocean Dashboard). 

  

http://explorer.copico.io:3002/
http://explorer.copico.io:3002/
https://www.digitalocean.com/
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5. Local Wallet Setup 
In your local wallet, go to: 

 File > Receiving Addresses 

 Click New 

Here you will label your masternode (otherwise known as your ‘ALIAS’); something easily recognisable, 

especially if you have multiple nodes. E.g. ‘CazMN1’. 

 Click OK to generate an address. 

 

Once you’ve clicked OK the new address will then be displayed. Copy this address. 

 Go to the Send menu; 

 Paste in the address in the Pay To field (the Label should then change to show the name you 

created for your masternode address); 

 Click on Inputs and select the inputs you’d like to use to send the 50,000 coins you wish to use 

for your masternode; 

Note: If they’re unlocked it could be that your wallet was unlocked and staking, if this is the 

case, lock your wallet and wait for them to become available. 

 When you’ve confirmed the details are correct, click the Send button (this is ultimately sending 

coins to yourself); 

 Go to the Transactions tab and double click on the transaction you just made; and 
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 Record the TRANSACTION_ID in Notepad as it will be required. You will also need to wait 

for 15 confirmations before continuing. 

Now we need to generate three pieces of information required to set your configurations up. Do the 

following: 

 Go to Tools and click Debug Console; 

 Type masternode genkey – record this in notepad – this is your ‘PRIVATE_KEY’; and 

 Type masternode outputs – you’ll receive a line which is your TRANSACTION_ID plus a single 

digit after; record this single digit in notepad record this in notepad – this is your ‘INDEX_ID’. 

 

6. Edit Local Config Files 
The next step is to alter your wallet.config file. To do this, go to Tools > Open Wallet Configuration 

File 

 

This will open a blank Notepad document. In this document, add the following text: 

rpcallowip=127.0.0.1 
rpcuser= cazcoinrpc 
rpcpassword=ANYOLDPASSWORD 
staking=1 
server=1 
listen=1 
port=17350 
masternode=1 
masternodeaddr= VPS_IP:17350 

externalip= VPS_IP:17350 

masternodeprivkey=YOUR_MASTERNODE_PRIVATE_KEY  

addnode=45.32.172.67 

addnode=185.183.99.19 

addnode=45.77.80.117 

addnode=185.150.191.23 

addnode=108.61.213.14:17350 

addnode=144.202.44.113:17350 

Save this. 
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Next you need to open the masternode.conf file. To do this, go to Tools > Open Masternode 

Configuration File 

 

This will open a Notepad document with three lines already pre-populated. In this document, add blank 

line, then on the next line add the following line: 

ALIAS VPS_IP:17350 PRIVATE_KEY TRANSACTION_ID INDEX ID 
(There is a single space between the items) 

It will end up looking something like the following: 

 

Save this. 

 

7. VPS Setup 
Now is the point you need to log in to your droplet via Putty. When you open Putty, you will see the 

below screen: 

  



CazCoin – VPS Masternode Setup  May 2018 

CazCoin 
 

Log in using the VPS_IP address you were assigned for your droplet. Enter the IP in to the highlighted 

field, then click ‘Open’. 

You will then see the log in screen for droplet. 

Login as: root 

Password: The temporary password emailed to you from Digital Ocean (or alternative VPS provider). 

Note: You will not be able to see what you are typing when entering the password, but it will work. 

Another alternative is to copy the password from your email, then right click in the screen, which is used 

to paste, then press enter. 

 
Login screen (where you won’t see the password being typed) 

Upon first log in you will be asked to reset your password. Again you will not see what you type: 

 
Change password screen 

When you’ve successfully reset your password, you will receive the welcome screen: 

 
Welcome screen 

Once you’ve reached this step you will need to start entering the commands to build your VPS. Copy 

and paste the below commands once at a time, pressing ‘Enter’ after each. Remember that you can right 

click in the command window to paste what you’ve copied: 

sudo fallocate -l 4G /swapfile 

sudo chmod 600 /swapfile 

sudo mkswap /swapfile 

sudo swapon /swapfile 

echo '/swapfile none swap sw 0 0' | sudo tee -a /etc/fstab 
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The next part is to install the Nano text editor: 

sudo apt-get update 

sudo apt-get install nano 

Now we install dependencies: 

sudo apt-get install build-essential libtool autotools-dev automake pkg-config libssl-dev libevent-dev 

bsdmainutils libboost-all-dev curl 
Note, the above is ONE line [starting with ‘sudo’ and ending in ‘curl’. This will ask if you want to use XXmb 

amount of data. Press Y and Enter – This step may take some time. 

 

sudo apt install software-properties-common 

sudo add-apt-repository ppa:bitcoin/bitcoin 

(This will ask if you want to continue – Press Enter) 

sudo apt-get update 

sudo apt-get install libdb4.8-dev libdb4.8++-dev 

sudo apt-get install libminiupnpc-dev 

The next stage is to build the CAZ wallet on the VPS: 

wget https://github.com/copicogithub1/cazcoin/releases/download/v.1.0.0/cazcoin-1.0.0-x86_64-linux-gnu.tar.gz 

Note: the above is a single line, beginning with ‘wget’ and ending with ‘tar.gz’. 

 

 

tar -xvzf cazcoin-1.0.0-x86_64-linux-gnu.tar.gz 

rm cazcoin-1.0.0-x86_64-linux-gnu.tar.gz 

mv cazcoin-1.0.0 cazcoin 

cd cazcoin/bin 

./cazcoind 

The next stage is to open the VPS CazCoin wallet configuration file and enter the same information as 

with the desktop wallet.conf (unless you have multiple masternodes running). Enter: 

nano ~/.cazcoin/cazcoin.conf 

The easiest way at this stage is to copy the wallet configuration information from your desktop wallet 

(unless running multiple masternodes) and right click to paste it in the command window. 

To save this configuration, enter the following: 

CTRL + O 

Enter 

CTRL + X 

Now we need to open the masternode configuration file and enter the same details as the desktop 

wallet’s masternode configuration file. Enter: 

nano ~/.cazcoin/masternode.conf 

To save this configuration, enter the following: 

CTRL + O 

Enter 

CTRL + X 
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Now to start your wallet, type the following: 

./cazcoind -daemon 

Once this command is entered it will start to download the CazCoin blockchain, which could take 

approximately 10-15 minutes. 

To check the progress of the download, enter the following: 

./cazcoin-cli getblockcount 

Compare the number received from this command with the latest block number on the  

CazCoin Explorer. 

Once the numbers match, to go your desktop wallet, to start your masternode! 

*Note, if you have issues with the blockcount staying at zero, refer to the troubleshooting section 

below. 

 

8. Starting the Masternode 
If your desktop wallet is still open, close it then reopen it and let it resync. 

 Unlock your wallet from the ‘Settings’ tab 

 Go to the ‘Masternodes’ tab and select the line corresponding to the masternode 

 Click ‘Start-Alias’ 

 Click ‘Yes’ to confirm 

You should now receive the message ‘Successfully started masternode.’  

 

However if you receive an error and the status still shows as ‘Missing’, go to the debug console via the 

‘Tools’ menu and enter the following: 

Masternode start-missing 

Press enter 

If the masternode has been set up correctly this should change the status from ‘Missing’ to ‘Enabled’. 

http://explorer.copico.io:3002/
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To double-check the masternode has started on the VPS, enter the below command which will tell you 

if your masternode has successfully started: 

./cazcoin-cli masternode status 

 

Payout: The time it takes to receive your first masternode payout can vary, but is generally 3-5 hours. 

 

9. Wallet Staking 
Once your masternode/s are working on the VPS and you’re receiving rewards, you can unlock your 

local desktop wallet for staking any coins you have above the masternode collateral (note, to do this 

you must keep your PC on 24/7). To do this: 

 Go to Settings > Unlock Wallet 

 Type in your password and click the tickbox ‘For Staking and Optimisation Only’. 
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10. Multiple Masternodes 
If you’re lucky enough to have enough coins for more than one masternode, you can configure your 

desktop configuration files so that all masternodes will display. 

 Each masternode will require its own VPS droplet, as the IP address needs to be unique; 

 Each masternode will require a separate Masternode PRIVATE_KEY (as per instructions above 

for singe masternode setup); 

Once you’ve generated the required information (PRIVATE_KEY, TRANSACTION_ID, INDEX_ID) 

etc., you will need to modify your local masternode.conf file to add the extra lines for the additional 

masternode/s. E.g. 

 

In your local wallet.conf file you will need to add the additional private key for the additional 

masternode/s. E.g. 

 

Note: The configuration files on the VPS will remain the same as if they were a single masternode (i.e. 

the files on the VPS only need to reflect their own config, not the other masternodes). 

Once the additional node has been configured, restart your local wallet, then go to the Masternodes tab 

and start the masternode, as per previous instructions. If the masternode has been set up correctly this 

should change the status from ‘Missing’ to ‘Enabled’. 

 

11. Troubleshooting 
Masternode not showing as enabled: 
If the masternode does not show up as enabled, or you get an error after starting , ensure to go back 

over and check the config files are correct as per the steps required. Ensure any data you may have 

copied and pasted is correct, with correct spacing and characters. 

Invalid IP Error: 

If the masternode is not showing as enabled, and as ‘MISSING’ in its place, and you get an IP error when 

starting alias, A solution for this can sometimes be to start it from the debug console. 

From the debug console write ‘masternode start-missing’ and click enter. This may start the masternode. 

If it does, the status should go from MISSING to ENABLED. 
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VPS Blockcount at Zero or Stuck: 

When starting the daemon on your VPS, if the blockcount stays at zero (0) and does not go up, do the 

following: 

 Check the addnodes are in the VPS wallet configuration; 

 Exit the VPS; 

 Log back in to the VPS, then enter: 

cd cazcoin/bin 

./cazcoind -daemon 

./cazcoin-cli getblockcount 

If the issue persists and the block count does not go up, enter the following: 

./cazcoin-cli stop 

./cazcoind -daemon 

It should then sync with the blockchain. 

Can’t Sent Collateral to Masternode Address: 

If you’re unable to send the 50,000 coin collateral to your new masternode receiving address, ensure 

your wallet is not unlocked and staking, as if the coins have recently staked, you will not be able to send 

them. If it has, lock your wallet and wait until the coins become available. 

Further troubleshooting 

Firewall:  

If your wallet won’t open/continually closes, ensure your antivirus (e.g. Windows Defender) is not 

blocking the CazCoin program. 

 

If you have further issues, feel free to contact a CazCoin admin on Telegram or Discord. 

 

12. Where to Buy 
 

 

 

 

Note: Check CazCoin website for up-to-date exchange listings. 

  

https://web.telegram.org/#/im?p=g304694303
https://discord.gg/UUzNR6e
http://cazcoin.io/
https://www.coinexchange.io/market/CAZ/BTC
https://wallet.crypto-bridge.org/market/BRIDGE.CAZ_BRIDGE.BTC
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13. Visit Us 
 

www.CazCoin.io 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

-Masternode instructions developed by Fever Pitch (@ITK2018) & Count (@Countalicious)- 

-Masternode guide developed and compiled by Count (@Countalicious)- 

http://www.cazcoin.io/
https://discord.gg/UUzNR6e
https://github.com/copicogithub1/cazcoin
https://bitcointalk.org/index.php?topic=3731308.0
https://www.reddit.com/r/CAZCOIN/
https://web.telegram.org/#/im?p=g304694303
https://twitter.com/cazproject

